Vulnerability · Published May 14, 2024 · Assigned by GitHub_M

CVE-2024-34716PrestaShop vulnerable to XSS via customer contact form in FO, through file upload

Critical 9.7

In plain English

A critical-severity cross-site scripting in PrestaShop from PrestaShop. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 56.4% (higher than 99.1% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.7Critical
Exploit odds (30 days)56.4%top 0.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

PrestaShop is an open source e-commerce web application. A cross-site scripting (XSS) vulnerability that only affects PrestaShops with customer-thread feature flag enabled is present starting from PrestaShop 8.1.0 and prior to PrestaShop 8.1.6. When the customer thread feature flag is enabled through the front-office contact form, a hacker can upload a malicious file containing an XSS that will be executed when an admin opens the attached file in back office. The script injected can access the session and the security token, which allows it to perform any authenticated action in the scope of the administrator's right. This vulnerability is patched in 8.1.6. A workaround is to disable the customer-thread feature-flag.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistprestashop/prestashop8.1.6GHSA-45vm-3j38-7p78

Affected products (as reported)

VendorProductVersions
PrestaShop PrestaShop >= 8.1.0, < 8.1.6

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

References