Vulnerability · Published May 14, 2024 · Assigned by GitHub_M
CVE-2024-34713sshproxy vulnerable to SSH option injection
Low 3.5
In plain English
A low-severity command injection in sshproxy from cea-hpc. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
sshproxy is used on a gateway to transparently proxy a user SSH connection on the gateway to an internal host via SSH. Prior to version 1.6.3, any user authorized to connect to a ssh server using `sshproxy` can inject options to the `ssh` command executed by `sshproxy`. All versions of `sshproxy` are impacted. The problem is patched starting in version 1.6.3. The only workaround is to use the `force_command` option in `sshproxy.yaml`, but it's rarely relevant.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Go | github.com/cea-hpc/sshproxy | 1.6.3 | GHSA-jmqp-37m5-49wh |
| Go | github.com/cea-hpc/sshproxy | 1.6.3 | GO-2024-2836 |
Affected products (as reported)
Weakness: CWE-77 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N