Vulnerability · Published Jun 20, 2024 · Assigned by apache

CVE-2024-34693Apache Superset: Server arbitrary file read

Medium 6.8

In plain English

A medium-severity improper input validation in Apache Superset from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.6% (higher than 76% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.8Medium
Exploit odds (30 days)1.6%top 24.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Improper Input Validation vulnerability in Apache Superset, allows for an authenticated attacker to create a MariaDB connection with local_infile enabled. If both the MariaDB server (off by default) and the local mysql client on the web server are set to allow for local infile, it's possible for the attacker to execute a specific MySQL/MariaDB SQL command that is able to read files from the server and insert their content on a MariaDB database table.This issue affects Apache Superset: before 3.1.3 and version 4.0.0 Users are recommended to upgrade to version 4.0.1 or 3.1.3, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapache-superset3.1.3GHSA-hcr7-cqwc-q5gq
PyPIapache-superset4.0.1GHSA-hcr7-cqwc-q5gq
PyPIapache-superset3.1.3, 4.0.1PYSEC-2026-1183

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Superset 0 – before 3.1.34.0.0 – before 4.0.1

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N

References