Vulnerability · Published May 3, 2024 · Assigned by GitHub_M
CVE-2024-34072Deserialization of Untrusted Data in sagemaker-python-sdk
High 7.8
In plain English
A high-severity unsafe deserialization in sagemaker-python-sdk from aws. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
sagemaker-python-sdk is a library for training and deploying machine learning models on Amazon SageMaker. The sagemaker.base_deserializers.NumpyDeserializer module before v2.218.0 allows potentially unsafe deserialization when untrusted data is passed as pickled object arrays. This consequently may allow an unprivileged third party to cause remote code execution, denial of service, affecting both confidentiality and integrity. Users are advised to upgrade to version 2.218.0. Users unable to upgrade should not pass pickled numpy object arrays which originated from an untrusted source, or that could have been tampered with. Only pass pickled numpy object arrays from trusted sources.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | sagemaker | 2.218.0 | GHSA-wjvx-jhpj-r54r |
| PyPI | sagemaker | 2.218.0 | PYSEC-2026-1889 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| aws | sagemaker-python-sdk | < 2.218.0 |
Weakness: CWE-502 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://github.com/aws/sagemaker-python-sdk/security/advisories/GHSA-wjvx-jhpj-r54r x_refsource_CONFIRM
- https://github.com/aws/sagemaker-python-sdk/pull/4557 x_refsource_MISC