Vulnerability · Published May 27, 2024 · Assigned by GitHub_M
CVE-2024-32978Kaminari Insecure File Permissions Vulnerability
Medium 6.6
In plain English
A medium-severity incorrect default permissions in kaminari from kaminari. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Kaminari is a paginator for web app frameworks and object relational mappings. A security vulnerability involving insecure file permissions has been identified in the Kaminari pagination library for Ruby on Rails, concerning insecure file permissions. This vulnerability is of moderate severity due to the potential for unauthorized write access to particular Ruby files managed by the library. Such access could lead to the alteration of application behavior or data integrity issues. Users of affected versions are advised to update to Kaminari version 0.16.2 or later, where file permissions have been adjusted to enhance security. If upgrading is not feasible immediately, review and adjust the file permissions for particular Ruby files in Kaminari to ensure they are only accessible by authorized user.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| RubyGems | kaminari | 0.16.2 | GHSA-7r3j-qmr4-jfpj |
| Ubuntu:22.04:LTS | ruby-kaminari | no fix listed | UBUNTU-CVE-2024-32978 |
| Ubuntu:24.04:LTS | ruby-kaminari | no fix listed | UBUNTU-CVE-2024-32978 |
| Ubuntu:25.10 | ruby-kaminari | no fix listed | UBUNTU-CVE-2024-32978 |
| Ubuntu:26.04:LTS | ruby-kaminari | no fix listed | UBUNTU-CVE-2024-32978 |
| Ubuntu:26.10 | ruby-kaminari | no fix listed | UBUNTU-CVE-2024-32978 |
Affected products (as reported)
Weakness: CWE-276 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/kaminari/kaminari/security/advisories/GHSA-7r3j-qmr4-jfpj x_refsource_CONFIRM