Vulnerability · Published May 9, 2024 · Assigned by GitHub_M

CVE-2024-32655Npgsql Vulnerable to SQL Injection via Protocol Message Size Overflow

High 8.1

In plain English

A high-severity integer overflow in npgsql from npgsql. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.7% (higher than 78% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)1.7%top 22.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Npgsql is the .NET data provider for PostgreSQL. The `WriteBind()` method in `src/Npgsql/Internal/NpgsqlConnector.FrontendMessages.cs` uses `int` variables to store the message length and the sum of parameter lengths. Both variables overflow when the sum of parameter lengths becomes too large. This causes Npgsql to write a message size that is too small when constructing a Postgres protocol message to send it over the network to the database. When parsing the message, the database will only read a small number of bytes and treat any following bytes as new messages while they belong to the old message. Attackers can abuse this to inject arbitrary Postgres protocol messages into the connection, leading to the execution of arbitrary SQL statements on the application's behalf. This vulnerability is fixed in 4.0.14, 4.1.13, 5.0.18, 6.0.11, 7.0.7, and 8.0.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
NuGetnpgsql8.0.3GHSA-x9vc-6hfv-hg8c
NuGetnpgsql4.0.14GHSA-x9vc-6hfv-hg8c
NuGetnpgsql4.1.13GHSA-x9vc-6hfv-hg8c
NuGetnpgsql5.0.18GHSA-x9vc-6hfv-hg8c
NuGetnpgsql6.0.11GHSA-x9vc-6hfv-hg8c
NuGetnpgsql7.0.7GHSA-x9vc-6hfv-hg8c
Ubuntu:22.04:LTSnpgsqlno fix listedUBUNTU-CVE-2024-32655
Ubuntu:24.04:LTSnpgsqlno fix listedUBUNTU-CVE-2024-32655

Affected products (as reported)

VendorProductVersions
npgsql npgsql >= 4.0.0, < 4.0.14>= 4.1.0, < 4.1.13>= 5.0.0, < 5.0.18>= 6.0.0, < 6.0.11>= 7.0.0, < 7.0.7>= 8.0.0, < 8.0.3

Weakness: CWE-190, CWE-89 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

References