Vulnerability · Published Apr 18, 2024 · Assigned by GitHub_M
CVE-2024-32474Sentry's superuser cleartext password leaked in logs
High 7.3
In plain English
A high-severity security flaw in sentry from getsentry. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Sentry is an error tracking and performance monitoring platform. Prior to 24.4.1, when authenticating as a superuser to Sentry with a username and password, the password is leaked as cleartext in logs under the _event_: `auth-index.validate_superuser`. An attacker with access to the log data could use these leaked credentials to login to the Sentry system as superuser. Self-hosted users on affected versions should upgrade to 24.4.1 or later. Users can configure the logging level to exclude logs of the `INFO` level and only generate logs for levels at `WARNING` or more.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | sentry | 24.4.1 | GHSA-6cjm-4pxw-7xp9 |
| PyPI | sentry | 24.4.1 | PYSEC-2026-1911 |
Affected products (as reported)
Weakness: CWE-312, CWE-117 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
References
- https://github.com/getsentry/sentry/security/advisories/GHSA-6cjm-4pxw-7xp9 x_refsource_CONFIRM
- https://github.com/getsentry/sentry/pull/66393 x_refsource_MISC
- https://github.com/getsentry/sentry/pull/69148 x_refsource_MISC
- https://github.com/getsentry/sentry/commit/d5b34568d9f1c41362ccb62141532a0a2169512f x_refsource_MISC