Vulnerability · Published Apr 18, 2024 · Assigned by GitHub_M

CVE-2024-32473Moby IPv6 enabled on IPv4-only network interfaces

Medium 4.7

In plain English

A medium-severity security flaw in moby from moby. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.7Medium
Exploit odds (30 days)0.4%top 71.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Moby is an open source container framework that is a key component of Docker Engine, Docker Desktop, and other distributions of container tooling or runtimes. In 26.0.0, IPv6 is not disabled on network interfaces, including those belonging to networks where `--ipv6=false`. An container with an `ipvlan` or `macvlan` interface will normally be configured to share an external network link with the host machine. Because of this direct access, (1) Containers may be able to communicate with other hosts on the local network over link-local IPv6 addresses, (2) if router advertisements are being broadcast over the local network, containers may get SLAAC-assigned addresses, and (3) the interface will be a member of IPv6 multicast groups. This means interfaces in IPv4-only networks present an unexpectedly and unnecessarily increased attack surface. The issue is patched in 26.0.2. To completely disable IPv6 in a container, use `--sysctl=net.ipv6.conf.all.disable_ipv6=1` in the `docker create` or `docker run` command. Or, in the service configuration of a `compose` file.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Alpine:v3.20docker26.0.2-r0ALPINE-CVE-2024-32473
Alpine:v3.21docker26.0.2-r0ALPINE-CVE-2024-32473
Alpine:v3.22docker26.0.2-r0ALPINE-CVE-2024-32473
Alpine:v3.23docker26.0.2-r0ALPINE-CVE-2024-32473
Alpine:v3.24docker26.0.2-r0ALPINE-CVE-2024-32473
Debian:12docker.iono fix listedDEBIAN-CVE-2024-32473
Debian:13docker.io26.1.4+dfsg1-9DEBIAN-CVE-2024-32473
Debian:14docker.io26.1.4+dfsg1-9DEBIAN-CVE-2024-32473
Gogithub.com/docker/docker26.0.2GHSA-x84c-p2g9-rqv9
Gogithub.com/docker/docker26.0.2+incompatibleGO-2024-2737
Ubuntu:22.04:LTSdocker.io-app27.5.1-0ubuntu3~22.04.2UBUNTU-CVE-2024-32473

Affected products (as reported)

VendorProductVersions
moby moby >= 26.0.0, < 26.0.2

Weakness: CWE-668 · Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N

References