Vulnerability · Published Aug 2, 2024 · Assigned by Wordfence
CVE-2024-3238WordPress Menu Plugin — Superfly Responsive Menu <= 5.0.29 - Cross-Site Request Forgery to Arbitrary File Deletion
High 8.8
In plain English
A high-severity cross-site request forgery in WordPress Menu Plugin — Superfly Responsive Menu from looks_awesome. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities).
Official description
The WordPress Menu Plugin — Superfly Responsive Menu plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 5.0.29. This is due to missing or incorrect nonce validation on the ajax_handle_delete_icons() function. This makes it possible for unauthenticated attackers to delete arbitrary files via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. Please not the CSRF was patched in 5.0.28, however, adequate directory traversal protection wasn't introduced until 5.0.30.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| looks_awesome | WordPress Menu Plugin — Superfly Responsive Menu | 0 – through 5.0.29 |
Weakness: CWE-352 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H