Vulnerability · Published Apr 2, 2024 · Assigned by VulDB

CVE-2024-3204c-blosc2 ndlz4x4.c ndlz4_decompress heap-based overflow

High 7.3

In plain English

A high-severity heap buffer overflow in c-blosc2. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 70% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)1.3%top 29.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A vulnerability has been found in c-blosc2 up to 2.13.2 and classified as critical. Affected by this vulnerability is the function ndlz4_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz4x4.c. The manipulation leads to heap-based buffer overflow. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-259051.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13c-blosc22.13.1+ds-3DEBIAN-CVE-2024-3204
Debian:14c-blosc22.13.1+ds-3DEBIAN-CVE-2024-3204
Ubuntu:24.04:LTSc-blosc2no fix listedUBUNTU-CVE-2024-3204
Ubuntu:25.10c-blosc2no fix listedUBUNTU-CVE-2024-3204
Ubuntu:26.04:LTSc-blosc2no fix listedUBUNTU-CVE-2024-3204
Ubuntu:26.10c-blosc2no fix listedUBUNTU-CVE-2024-3204

Affected products (as reported)

VendorProductVersions
n/a c-blosc2 2.13.02.13.12.13.2

Weakness: CWE-122 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

References