Vulnerability · Published Apr 16, 2024 · Assigned by GitHub_M

CVE-2024-32025Kohya_ss is vulnerable to a command injection in `group_images_gui.py` (`GHSL-2024-021`)

Critical 9.1

In plain English

A critical-severity command injection in kohya_ss from bmaltais. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.5% (higher than 85% of all known vulnerabilities).

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)2.5%top 15.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Kohya_ss is a GUI for Kohya's Stable Diffusion trainers. Kohya_ss is vulnerable to a command injection in `group_images_gui.py`. This vulnerability is fixed in 23.1.5.

Affected products (as reported)

VendorProductVersions
bmaltais kohya_ss >= 22.6.1, < 23.1.5

Weakness: CWE-77 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

References