Vulnerability · Published Oct 7, 2024 · Assigned by GitHub_M

CVE-2024-31449Lua library commands may lead to stack overflow and RCE in Redis

High 7.0

In plain English

A high-severity improper input validation in redis from redis. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 4.5% (higher than 91% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.0High
Exploit odds (30 days)4.5%top 8.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack tooling1Public PoC

Official description

Redis is an open source, in-memory database that persists on disk. An authenticated user may use a specially crafted Lua script to trigger a stack buffer overflow in the bit library, which may potentially lead to remote code execution. The problem exists in all versions of Redis with Lua scripting. This problem has been fixed in Redis versions 6.2.16, 7.2.6, and 7.4.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8redis6.2.17-1.module_el8.10.0+3946+3de613d5ALSA-2025:0595
AlmaLinux:9redis6.2.17-1.el9_5ALSA-2025:0693
AlmaLinux:9redis7.2.6-1.module_el9.5.0+130+36ae7635ALSA-2024:10869
AlmaLinux:8redis-devel6.2.17-1.module_el8.10.0+3946+3de613d5ALSA-2025:0595
AlmaLinux:9redis-devel7.2.6-1.module_el9.5.0+130+36ae7635ALSA-2024:10869
AlmaLinux:9redis-devel6.2.17-1.el9_5ALSA-2025:0693
AlmaLinux:8redis-doc6.2.17-1.module_el8.10.0+3946+3de613d5ALSA-2025:0595
AlmaLinux:9redis-doc6.2.17-1.el9_5ALSA-2025:0693
AlmaLinux:9redis-doc7.2.6-1.module_el9.5.0+130+36ae7635ALSA-2024:10869
Alpine:v3.20redict7.3.1-r0ALPINE-CVE-2024-31449
Alpine:v3.21redict7.3.1-r0ALPINE-CVE-2024-31449
Alpine:v3.22redict7.3.1-r0ALPINE-CVE-2024-31449
Alpine:v3.23redict7.3.1-r0ALPINE-CVE-2024-31449
Alpine:v3.24redict7.3.1-r0ALPINE-CVE-2024-31449
Alpine:v3.20redis7.2.5-r1ALPINE-CVE-2024-31449
Alpine:v3.21redis7.2.5-r1ALPINE-CVE-2024-31449
Alpine:v3.22redis7.2.5-r1ALPINE-CVE-2024-31449
Alpine:v3.23redis7.2.5-r1ALPINE-CVE-2024-31449
Alpine:v3.24redis7.2.5-r1ALPINE-CVE-2024-31449
Alpine:v3.20valkey7.2.7-r0ALPINE-CVE-2024-31449
Alpine:v3.21valkey7.2.7-r0ALPINE-CVE-2024-31449
Alpine:v3.22valkey7.2.7-r0ALPINE-CVE-2024-31449
Alpine:v3.23valkey7.2.7-r0ALPINE-CVE-2024-31449
Alpine:v3.24valkey7.2.7-r0ALPINE-CVE-2024-31449
Debian:14redict7.3.1+ds-1DEBIAN-CVE-2024-31449
Debian:12redis5:7.0.15-1~deb12u2DEBIAN-CVE-2024-31449
Debian:13redis5:7.0.15-2DEBIAN-CVE-2024-31449
Debian:14redis5:7.0.15-2DEBIAN-CVE-2024-31449
Debian:13valkey8.0.1+dfsg1-1DEBIAN-CVE-2024-31449
Debian:14valkey8.0.1+dfsg1-1DEBIAN-CVE-2024-31449
Rocky Linux:8redis0:6.2.17-1.module+el8.10.0+1923+5b85c6a7RLSA-2025:0595
Rocky Linux:9redis0:6.2.17-1.el9_5RLSA-2025:0693
Ubuntu:24.04:LTSlua-bitopno fix listedUBUNTU-CVE-2024-31449
Ubuntu:25.10lua-bitopno fix listedUBUNTU-CVE-2024-31449
Ubuntu:26.04:LTSlua-bitopno fix listedUBUNTU-CVE-2024-31449
Ubuntu:26.10lua-bitopno fix listedUBUNTU-CVE-2024-31449
Ubuntu:24.04:LTSredis5:7.0.15-1ubuntu0.24.04.4UBUNTU-CVE-2024-31449

Affected products (as reported)

VendorProductVersions
redis redis >= 2.6, < 6.2.16>= 7.0.0, < 7.2.6>= 7.3.0, < 7.4.1

Weakness: CWE-20, CWE-121 · Vector: CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

References