Vulnerability · Published Apr 8, 2024 · Assigned by GitHub_M
CVE-2024-31447Shopware has Improper Session Handling in store-api
Medium 5.3
In plain English
A medium-severity security flaw in shopware from shopware. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Shopware 6 is an open commerce platform based on Symfony Framework and Vue. Starting in version 6.3.5.0 and prior to versions 6.6.1.0 and 6.5.8.8, when a authenticated request is made to `POST /store-api/account/logout`, the cart will be cleared, but the User won't be logged out. This affects only the direct store-api usage, as the PHP Storefront listens additionally on `CustomerLogoutEvent` and invalidates the session additionally. The problem has been fixed in Shopware 6.6.1.0 and 6.5.8.8. Those who are unable to update can install the latest version of the Shopware Security Plugin as a workaround.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | shopware/core | 6.5.8.8 | GHSA-5297-wrrp-rcj7 |
| Packagist | shopware/core | 6.6.1.0 | GHSA-5297-wrrp-rcj7 |
| Packagist | shopware/platform | 6.5.8.8 | GHSA-5297-wrrp-rcj7 |
| Packagist | shopware/platform | 6.6.1.0 | GHSA-5297-wrrp-rcj7 |
Affected products (as reported)
Weakness: CWE-613 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N