Vulnerability · Published Apr 4, 2024 · Assigned by GitHub_M
CVE-2024-31211Remote Code Execution in `WP_HTML_Token`
Medium 5.5
In plain English
A medium-severity unsafe deserialization in wordpress-develop from WordPress. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.7% (higher than 86% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
WordPress is an open publishing platform for the Web. Unserialization of instances of the `WP_HTML_Token` class allows for code execution via its `__destruct()` magic method. This issue was fixed in WordPress 6.4.2 on December 6th, 2023. Versions prior to 6.4.0 are not affected.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:13 | wordpress | 6.4.2+dfsg1-1 | DEBIAN-CVE-2024-31211 |
| Debian:14 | wordpress | 6.4.2+dfsg1-1 | DEBIAN-CVE-2024-31211 |
| Ubuntu:22.04:LTS | wordpress | no fix listed | UBUNTU-CVE-2024-31211 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| WordPress | wordpress-develop | >= 6.4.0 < 6.4.2 |
Weakness: CWE-502 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N