Vulnerability · Published Apr 4, 2024 · Assigned by GitHub_M

CVE-2024-31210PHP file upload bypass via Plugin installer

High 7.7

In plain English

A high-severity unrestricted file upload in wordpress-develop from WordPress. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 63% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.7High
Exploit odds (30 days)1.0%top 37.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

WordPress is an open publishing platform for the Web. It's possible for a file of a type other than a zip file to be submitted as a new plugin by an administrative user on the Plugins -> Add New -> Upload Plugin screen in WordPress. If FTP credentials are requested for installation (in order to move the file into place outside of the `uploads` directory) then the uploaded file remains temporary available in the Media Library despite it not being allowed. If the `DISALLOW_FILE_EDIT` constant is set to `true` on the site _and_ FTP credentials are required when uploading a new theme or plugin, then this technically allows an RCE when the user would otherwise have no means of executing arbitrary PHP code. This issue _only_ affects Administrator level users on single site installations, and Super Admin level users on Multisite installations where it's otherwise expected that the user does not have permission to upload or execute arbitrary PHP code. Lower level users are not affected. Sites where the `DISALLOW_FILE_MODS` constant is set to `true` are not affected. Sites where an administrative user either does not need to enter FTP credentials or they have access to the valid FTP credentials, are not affected. The issue was fixed in WordPress 6.4.3 on January 30, 2024 and backported to versions 6.3.3, 6.2.4, 6.1.5, 6.0.7, 5.9.9, 5.8.9, 5.7.11, 5.6.13, 5.5.14, 5.4.15, 5.3.17, 5.2.20, 5.1.18, 5.0.21, 4.9.25, 2.8.24, 4.7.28, 4.6.28, 4.5.31, 4.4.32, 4.3.33, 4.2.37, and 4.1.40. A workaround is available. If the `DISALLOW_FILE_MODS` constant is defined as `true` then it will not be possible for any user to upload a plugin and therefore this issue will not be exploitable.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12wordpress6.1.6+dfsg1-0+deb12u1DEBIAN-CVE-2024-31210
Debian:12wordpress6.1.6+dfsg1-0+deb12u1DSA-5685-1
Debian:13wordpress6.4.3+dfsg1-1DEBIAN-CVE-2024-31210
Debian:14wordpress6.4.3+dfsg1-1DEBIAN-CVE-2024-31210
Ubuntu:22.04:LTSwordpressno fix listedUBUNTU-CVE-2024-31210

Affected products (as reported)

VendorProductVersions
WordPress wordpress-develop >= 6.4.0, < 6.4.3>= 6.3.0, < 6.3.3>= 6.2.0, < 6.2.4>= 6.1.0, < 6.1.5>= 6.0.0, < 6.0.7>= 5.9.0, < 5.9.9>= 5.8.0, < 5.8.9>= 5.7.0, < 5.7.11

Weakness: CWE-434 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H

References