Vulnerability · Published Apr 23, 2024 · Assigned by GitHub_M
CVE-2024-31208Synapse's V2 state resolution weakness allows DoS from remote room members
Medium 6.5
In plain English
A medium-severity resource allocation without limits in synapse from element-hq. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.5% (higher than 74% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Synapse is an open-source Matrix homeserver. A remote Matrix user with malicious intent, sharing a room with Synapse instances before 1.105.1, can dispatch specially crafted events to exploit a weakness in the V2 state resolution algorithm. This can induce high CPU consumption and accumulate excessive data in the database of such instances, resulting in a denial of service. Servers in private federations, or those that do not federate, are not affected. Server administrators should upgrade to 1.105.1 or later. Some workarounds are available. One can ban the malicious users or ACL block servers from the rooms and/or leave the room and purge the room using the admin API.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.20 | synapse | 1.105.1-r0 | ALPINE-CVE-2024-31208 |
| Alpine:v3.21 | synapse | 1.105.1-r0 | ALPINE-CVE-2024-31208 |
| Alpine:v3.22 | synapse | 1.105.1-r0 | ALPINE-CVE-2024-31208 |
| Alpine:v3.23 | synapse | 1.105.1-r0 | ALPINE-CVE-2024-31208 |
| Alpine:v3.24 | synapse | 1.105.1-r0 | ALPINE-CVE-2024-31208 |
| Debian:14 | matrix-synapse | 1.103.0-2 | DEBIAN-CVE-2024-31208 |
| PyPI | matrix-synapse | 1.105.1 | PYSEC-2024-50 |
| PyPI | matrix-synapse | 1.105.1 | GHSA-3h7q-rfh9-xm4v |
| Ubuntu:24.04:LTS | matrix-synapse | no fix listed | UBUNTU-CVE-2024-31208 |
| Ubuntu:22.04:LTS | synapse | no fix listed | UBUNTU-CVE-2024-31208 |
| Ubuntu:24.04:LTS | synapse | no fix listed | UBUNTU-CVE-2024-31208 |
| Ubuntu:25.10 | synapse | no fix listed | UBUNTU-CVE-2024-31208 |
| Ubuntu:26.04:LTS | synapse | no fix listed | UBUNTU-CVE-2024-31208 |
| Ubuntu:26.10 | synapse | no fix listed | UBUNTU-CVE-2024-31208 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| element-hq | synapse | < 1.105.1 |
Weakness: CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/element-hq/synapse/security/advisories/GHSA-3h7q-rfh9-xm4v x_refsource_CONFIRM
- https://github.com/element-hq/synapse/commit/55b0aa847a61774b6a3acdc4b177a20dc019f01a x_refsource_MISC
- https://github.com/element-hq/synapse/releases/tag/v1.105.1 x_refsource_MISC
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/RR53FNHV446CB37TP45GZ6F6HZLZCK3K/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/R6FCCO4ODTZ3FDS7TMW76PKOSEL2TQVB/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/VSF4NJJSTSQRJQ47PLYYSCFYKJBP7DET/