Vulnerability · Published Apr 4, 2024 · Assigned by GitHub_M

CVE-2024-30250In Astro-Shield, setting a correct `integrity` attribute to injected code allows to bypass the allow-lists

High 7.5

In plain English

A high-severity insufficient verification of data authenticity in astro-shield from kindspells. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 24% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.3%top 76.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Astro-Shield is an integration to enhance website security with SubResource Integrity hashes, Content-Security-Policy headers, and other techniques. Versions from 1.2.0 to 1.3.1 of Astro-Shield allow bypass to the allow-lists for cross-origin resources by introducing valid `integrity` attributes to the injected code. This implies that the injected SRI hash would be added to the generated CSP header, which would lead the browser to believe that the injected resource is legit. This vulnerability is patched in version 1.3.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@kindspells/astro-shield1.3.2GHSA-c4gr-q97g-ppwc

Affected products (as reported)

VendorProductVersions
kindspells astro-shield >= 1.2.0, < 1.3.2

Weakness: CWE-345 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

References