Vulnerability · Published Mar 29, 2024 · Assigned by GitHub_M
CVE-2024-29890Remote code execution in datalens-ui
High 8.8
In plain English
A high-severity cross-site scripting in datalens from datalens-tech. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities).
Official description
DataLens is a business intelligence and data visualization system. A specifically crafted request allowed the creation of a special chart type with the ability to pass custom javascript code that would later be executed in an unprotected sandbox on subsequent requests to that chart. The problem was fixed in the datalens-ui version `0.1449.0`. Restricting access to the API for creating or modifying charts (`/charts/api/charts/v1/`) would mitigate the issue.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| datalens-tech | datalens | < 0.1449.0 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H