Vulnerability · Published Mar 26, 2024 · Assigned by GitHub_M

CVE-2024-29881TinyMCE Cross-Site Scripting (XSS) vulnerability in handling external SVG files through Object or Embed elements

Medium 4.3

In plain English

A medium-severity cross-site scripting in tinymce from tinymce. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.7%top 46.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content loading and content inserting code. A SVG image could be loaded though an `object` or `embed` element and that image could potentially contain a XSS payload. This vulnerability is fixed in 6.8.1 and 7.0.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
NuGettinymce7.0.0GHSA-5359-pvf2-pw78
Packagisttinymce/tinymce7.0.0GHSA-5359-pvf2-pw78
npmtinymce7.0.0GHSA-5359-pvf2-pw78

Affected products (as reported)

VendorProductVersions
tinymce tinymce < 7.0.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N

References