Vulnerability · Published Apr 2, 2024 · Assigned by apache

CVE-2024-29834Apache Pulsar: Improper Authorization For Namespace and Topic Management Endpoints

Medium 6.4

In plain English

A medium-severity incorrect authorization in Apache Pulsar from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.4% (higher than 72% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.4Medium
Exploit odds (30 days)1.4%top 28.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

This vulnerability allows authenticated users with produce or consume permissions to perform unauthorized operations on partitioned topics, such as unloading topics and triggering compaction. These management operations should be restricted to users with the tenant admin role or superuser role. An authenticated user with produce permission can create subscriptions and update subscription properties on partitioned topics, even though this should be limited to users with consume permissions. This impact analysis assumes that Pulsar has been configured with the default authorization provider. For custom authorization providers, the impact could be slightly different. Additionally, the vulnerability allows an authenticated user to read, create, modify, and delete namespace properties in any namespace in any tenant. In Pulsar, namespace properties are reserved for user provided metadata about the namespace. This issue affects Apache Pulsar versions from 2.7.1 to 2.10.6, from 2.11.0 to 2.11.4, from 3.0.0 to 3.0.3, from 3.1.0 to 3.1.3, and from 3.2.0 to 3.2.1. 3.0 Apache Pulsar users should upgrade to at least 3.0.4. 3.1 and 3.2 Apache Pulsar users should upgrade to at least 3.2.2. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.pulsar:pulsar-brokerno fix listedGHSA-7mg2-6c6v-342r
Mavenorg.apache.pulsar:pulsar-brokerno fix listedGHSA-7mg2-6c6v-342r
Mavenorg.apache.pulsar:pulsar-broker3.0.4GHSA-7mg2-6c6v-342r
Mavenorg.apache.pulsar:pulsar-brokerno fix listedGHSA-7mg2-6c6v-342r
Mavenorg.apache.pulsar:pulsar-broker3.2.2GHSA-7mg2-6c6v-342r

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Pulsar 2.7.1 – through 2.10.62.11.0 – through 2.11.43.0.0 – before 3.0.43.1.0 – through 3.1.33.2.0 – before 3.2.2

Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

References