Vulnerability · Published Apr 21, 2024 · Assigned by apache

CVE-2024-29733Apache Airflow FTP Provider: FTP_TLS instance with unverified SSL context

Low 2.7

In plain English

A low-severity improper certificate validation in Apache Airflow FTP Provider from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)2.7Low
Exploit odds (30 days)0.6%top 49.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Certificate Validation vulnerability in Apache Airflow FTP Provider. The FTP hook lacks complete certificate validation in FTP_TLS connections, which can potentially be leveraged. Implementing proper certificate validation by passing context=ssl.create_default_context() during FTP_TLS instantiation is used as mitigation to validate the certificates properly. This issue affects Apache Airflow FTP Provider: before 3.7.0. Users are recommended to upgrade to version 3.7.0, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapache-airflow-providers-ftp3.7.0GHSA-3gg8-mc87-cq3h
PyPIapache-airflow-providers-ftp3.7.0PYSEC-2026-1148

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Airflow FTP Provider 0 – before 3.7.0

Weakness: CWE-295 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N

References