Vulnerability · Published Apr 21, 2024 · Assigned by apache

CVE-2024-29217Apache Answer: XSS vulnerability when changing personal website

Medium 4.6

In plain English

A medium-severity cross-site scripting in Apache Answer from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 62% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.6Medium
Exploit odds (30 days)1.0%top 38.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Answer.This issue affects Apache Answer: before 1.3.0. XSS attack when user changes personal website. A logged-in user, when modifying their personal website, can input malicious code in the website to create such an attack. Users are recommended to upgrade to version [1.3.0], which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/apache/incubator-answer1.3.0GHSA-cvqr-mwh6-2vc6
Gogithub.com/apache/incubator-answer1.3.0GO-2024-2743

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Answer 0 – before 1.3.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:L

References