Vulnerability · Published Mar 26, 2024 · Assigned by GitHub_M

CVE-2024-29203TinyMCE Cross-Site Scripting (XSS) vulnerability in handling iframes

Medium 4.3

In plain English

A medium-severity cross-site scripting in tinymce from tinymce. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 54% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.7%top 46.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content insertion code. This allowed `iframe` elements containing malicious code to execute when inserted into the editor. These `iframe` elements are restricted in their permissions by same-origin browser protections, but could still trigger operations such as downloading of malicious assets. This vulnerability is fixed in 6.8.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
NuGettinymce6.8.1GHSA-438c-3975-5x3f
Packagisttinymce/tinymce6.8.1GHSA-438c-3975-5x3f
npmtinymce6.8.1GHSA-438c-3975-5x3f

Affected products (as reported)

VendorProductVersions
tinymce tinymce < 6.8.1

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N

References