Vulnerability · Published Jun 10, 2025 · Assigned by GitHub_M

CVE-2024-29198GeoServer Vulnerable to Unauthenticated SSRF via TestWfsPost

High 7.5

In plain English

A high-severity server-side request forgery in geoserver from geoserver. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.3% (higher than 84% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)2.3%top 16.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Nuclei

Official description

GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. It possible to achieve Service Side Request Forgery (SSRF) via the Demo request endpoint if Proxy Base URL has not been set. Upgrading to GeoServer 2.24.4, or 2.25.2, removes the TestWfsPost servlet resolving this issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.geoserver.web:gs-app2.24.4GHSA-5gw5-jccf-6hxw
Mavenorg.geoserver.web:gs-app2.25.2GHSA-5gw5-jccf-6hxw
Mavenorg.geoserver:gs-wfs2.24.4GHSA-5gw5-jccf-6hxw
Mavenorg.geoserver:gs-wfs2.25.2GHSA-5gw5-jccf-6hxw

Affected products (as reported)

VendorProductVersions
geoserver geoserver >= 2.0.0, < 2.24.4>= 2.25.0, < 2.25.2

Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

References