Vulnerability · Published Mar 24, 2024 · Assigned by GitHub_M
CVE-2024-29034CarrierWave's Content-Type allowlist bypass vulnerability which possibly leads to XSS remained
Medium 6.8
In plain English
A medium-severity cross-site scripting in carrierwave from carrierwaveuploader. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
CarrierWave is a solution for file uploads for Rails, Sinatra and other Ruby web frameworks. The vulnerability CVE-2023-49090 wasn't fully addressed. This vulnerability is caused by the fact that when uploading to object storage, including Amazon S3, it is possible to set a Content-Type value that is interpreted by browsers to be different from what's allowed by `content_type_allowlist`, by providing multiple values separated by commas. This bypassed value can be used to cause XSS. Upgrade to 3.0.7 or 2.2.6.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| RubyGems | carrierwave | 3.0.7 | GHSA-vfmv-jfc5-pjjw |
| RubyGems | carrierwave | 2.2.6 | GHSA-vfmv-jfc5-pjjw |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| carrierwaveuploader | carrierwave | >= 3.0.0, < 3.0.7< 2.2.6 |
Weakness: CWE-436, CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N