Vulnerability · Published Mar 25, 2024 · Assigned by GitHub_M

CVE-2024-28106phpMyFAQ Stored XSS at FAQ News Content

Medium 4.3

In plain English

A medium-severity cross-site scripting in phpMyFAQ from thorsten. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.5%top 54.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. By manipulating the news parameter in a POST request, an attacker can inject malicious JavaScript code. Upon browsing to the compromised news page, the XSS payload triggers. This vulnerability is fixed in 3.2.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistphpmyfaq/phpmyfaq3.2.6GHSA-6p68-36m6-392r

Affected products (as reported)

VendorProductVersions
thorsten phpMyFAQ 3.2.5

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L

References