Vulnerability · Published Jun 4, 2024 · Assigned by GitHub_M

CVE-2024-28103Action Pack is missing security headers on non-HTML responses

Medium 5.4

In plain English

A medium-severity improper input validation in rails from rails. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.7%top 48.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Action Pack is a framework for handling and responding to web requests. Since 6.1.0, the application configurable Permissions-Policy is only served on responses with an HTML related Content-Type. This vulnerability is fixed in 6.1.7.8, 7.0.8.2, and 7.1.3.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rails2:6.1.7.10+dfsg-1~deb12u1DEBIAN-CVE-2024-28103
Debian:12rails2:6.1.7.10+dfsg-1~deb12u1DSA-5881-1
Debian:13rails2:7.2.2.1+dfsg-1DEBIAN-CVE-2024-28103
Debian:14rails2:7.2.2.1+dfsg-1DEBIAN-CVE-2024-28103
RubyGemsactionpack6.1.7.8GHSA-fwhr-88qx-h9g7
RubyGemsactionpack7.0.8.4GHSA-fwhr-88qx-h9g7
RubyGemsactionpack7.1.3.4GHSA-fwhr-88qx-h9g7
RubyGemsactionpack7.2.0.beta2GHSA-fwhr-88qx-h9g7
Ubuntu:24.04:LTSrailsno fix listedUBUNTU-CVE-2024-28103
Ubuntu:25.10railsno fix listedUBUNTU-CVE-2024-28103
Ubuntu:26.04:LTSrailsno fix listedUBUNTU-CVE-2024-28103
Ubuntu:26.10railsno fix listedUBUNTU-CVE-2024-28103

Affected products (as reported)

VendorProductVersions
rails rails >= 6.1.0.0, < 6.1.7.8>= 7.0.0.0, < 7.0.8.4>= 7.1.0.0, < 7.1.3.4>= 7.2.0.beta1, < 7.2.0.beta2

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

References