Vulnerability · Published Mar 12, 2024 · Assigned by apache
CVE-2024-28098Apache Pulsar: Improper Authorization For Topic-Level Policy Management
Medium 6.4
In plain English
A medium-severity incorrect authorization in Apache Pulsar from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.7% (higher than 77% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
The vulnerability allows authenticated users with only produce or consume permissions to modify topic-level policies, such as retention, TTL, and offloading settings. These management operations should be restricted to users with the tenant admin role or super user role. This issue affects Apache Pulsar versions from 2.7.1 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Apache Pulsar users should upgrade to at least 2.10.6. 2.11 Apache Pulsar users should upgrade to at least 2.11.4. 3.0 Apache Pulsar users should upgrade to at least 3.0.3. 3.1 Apache Pulsar users should upgrade to at least 3.1.3. 3.2 Apache Pulsar users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.pulsar:pulsar-broker | 3.2.1 | GHSA-g627-r579-rw35 |
| Maven | org.apache.pulsar:pulsar-broker | 3.1.3 | GHSA-g627-r579-rw35 |
| Maven | org.apache.pulsar:pulsar-broker | 3.0.3 | GHSA-g627-r579-rw35 |
| Maven | org.apache.pulsar:pulsar-broker | 2.11.4 | GHSA-g627-r579-rw35 |
| Maven | org.apache.pulsar:pulsar-broker | 2.10.6 | GHSA-g627-r579-rw35 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Pulsar | 2.7.1 – before 2.10.62.11.0 – before 2.11.43.0.0 – before 3.0.33.1.0 – before 3.1.33.2.0 – before 3.2.1 |
Weakness: CWE-863 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N