Vulnerability · Published Mar 6, 2024 · Assigned by GitHub_M
CVE-2024-27922HTTP Handling Vulnerability in the Bare server
Critical 9.8
In plain English
A critical-severity security flaw in bare-server-node from tomphttp. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 58% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
TOMP Bare Server implements the TompHTTP bare server. A vulnerability in versions prior to 2.0.2 relates to insecure handling of HTTP requests by the @tomphttp/bare-server-node package. This flaw potentially exposes the users of the package to manipulation of their web traffic. The impact may vary depending on the specific usage of the package but it can potentially affect any system where this package is in use. The problem has been patched in version 2.0.2. As of time of publication, no specific workaround strategies have been disclosed.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @tomphttp/bare-server-node | 2.0.2 | GHSA-86fc-f9gr-v533 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| tomphttp | bare-server-node | < 2.0.2 |
Weakness: CWE-444 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H