Vulnerability · Published Apr 4, 2024 · Assigned by GitHub_M
CVE-2024-27919HTTP/2: memory exhaustion due to CONTINUATION frame flood
High 7.5
In plain English
A high-severity security flaw in envoy from envoyproxy. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 83.9% (higher than 99.7% of all known vulnerabilities).
Official description
Envoy is a cloud-native, open-source edge and service proxy. In versions 1.29.0 and 1.29.1, theEnvoy HTTP/2 protocol stack is vulnerable to the flood of CONTINUATION frames. Envoy's HTTP/2 codec does not reset a request when header map limits have been exceeded. This allows an attacker to send an sequence of CONTINUATION frames without the END_HEADERS bit set causing unlimited memory consumption. This can lead to denial of service through memory exhaustion. Users should upgrade to versions 1.29.2 to mitigate the effects of the CONTINUATION flood. Note that this vulnerability is a regression in Envoy version 1.29.0 and 1.29.1 only. As a workaround, downgrade to version 1.28.1 or earlier or disable HTTP/2 protocol for downstream connections.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| envoyproxy | envoy | >= 1.29.0, < 1.29.2 |
Weakness: CWE-390 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-gghf-vfxp-799r x_refsource_CONFIRM
- https://github.com/envoyproxy/envoy/commit/57a02565532c18eb9df972a3e8974be3ae59f2d5 x_refsource_MISC
- http://www.openwall.com/lists/oss-security/2024/04/05/3
- http://www.openwall.com/lists/oss-security/2024/04/03/16
- https://www.kb.cert.org/vuls/id/421644