Vulnerability · Published Jun 10, 2024 · Assigned by apple

CVE-2024-27838

Medium 6.5

In plain English

A medium-severity cross-site scripting in iOS and iPadOS from Apple. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.7%top 45.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

The issue was addressed by adding additional logic. This issue is fixed in Safari 17.5, iOS 16.7.8 and iPadOS 16.7.8, iOS 17.5 and iPadOS 17.5, macOS Sonoma 14.5, tvOS 17.5, visionOS 1.2, watchOS 10.5. A maliciously crafted webpage may be able to fingerprint the user.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8webkit2gtk32.46.3-1.el8_10ALSA-2024:9636
AlmaLinux:9webkit2gtk32.46.1-2.el9_4ALSA-2024:8180
AlmaLinux:8webkit2gtk3-devel2.46.3-1.el8_10ALSA-2024:9636
AlmaLinux:9webkit2gtk3-devel2.46.1-2.el9_4ALSA-2024:8180
AlmaLinux:8webkit2gtk3-jsc2.46.3-1.el8_10ALSA-2024:9636
AlmaLinux:9webkit2gtk3-jsc2.46.1-2.el9_4ALSA-2024:8180
AlmaLinux:8webkit2gtk3-jsc-devel2.46.3-1.el8_10ALSA-2024:9636
AlmaLinux:9webkit2gtk3-jsc-devel2.46.1-2.el9_4ALSA-2024:8180
Debian:12webkit2gtk2.44.3-1~deb12u1DEBIAN-CVE-2024-27838
Debian:12webkit2gtk2.44.3-1~deb12u1DSA-5762-1
Debian:13webkit2gtk2.44.3-1DEBIAN-CVE-2024-27838
Debian:14webkit2gtk2.44.3-1DEBIAN-CVE-2024-27838
Debian:12wpewebkitno fix listedDEBIAN-CVE-2024-27838
Debian:13wpewebkit2.44.3-1DEBIAN-CVE-2024-27838
Debian:14wpewebkit2.44.3-1DEBIAN-CVE-2024-27838
Rocky Linux:8webkit2gtk30:2.46.3-1.el8_10RLSA-2024:9636
Rocky Linux:9webkit2gtk30:2.46.1-2.el9_4RLSA-2024:8180
Ubuntu:22.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2024-27838
Ubuntu:24.04:LTSqtwebkit-opensource-srcno fix listedUBUNTU-CVE-2024-27838
Ubuntu:22.04:LTSwebkit2gtk2.44.3-0ubuntu0.22.04.1UBUNTU-CVE-2024-27838
Ubuntu:24.04:LTSwebkit2gtk2.44.3-0ubuntu0.24.04.1UBUNTU-CVE-2024-27838
Ubuntu:22.04:LTSwpewebkitno fix listedUBUNTU-CVE-2024-27838

Affected products (as reported)

VendorProductVersions
Apple Safari 0 – before 17.5
Apple iOS and iPadOS 0 – before 16.7.80 – before 17.5
Apple macOS 0 – before 14.5
Apple tvOS 0 – before 17.5
Apple visionOS 0 – before 1.2
Apple watchOS 0 – before 10.5

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

References