Vulnerability · Published Mar 12, 2024 · Assigned by apache

CVE-2024-27317Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification

High 8.4

In plain English

A high-severity path traversal in Apache Pulsar from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 56.9% (higher than 99.1% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.4High
Exploit odds (30 days)56.9%top 0.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

In Pulsar Functions Worker, authenticated users can upload functions in jar or nar files. These files, essentially zip files, are extracted by the Functions Worker. However, if a malicious file is uploaded, it could exploit a directory traversal vulnerability. This occurs when the filenames in the zip files, which aren't properly validated, contain special elements like "..", altering the directory path. This could allow an attacker to create or modify files outside of the designated extraction directory, potentially influencing system behavior. This vulnerability also applies to the Pulsar Broker when it is configured with "functionsWorkerEnabled=true". This issue affects Apache Pulsar versions from 2.4.0 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Pulsar Function Worker users should upgrade to at least 2.10.6. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.4. 3.0 Pulsar Function Worker users should upgrade to at least 3.0.3. 3.1 Pulsar Function Worker users should upgrade to at least 3.1.3. 3.2 Pulsar Function Worker users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.pulsar:pulsar-functions-worker2.10.6GHSA-jg2g-4rjg-cmqh
Mavenorg.apache.pulsar:pulsar-functions-worker2.11.4GHSA-jg2g-4rjg-cmqh
Mavenorg.apache.pulsar:pulsar-functions-worker3.0.3GHSA-jg2g-4rjg-cmqh
Mavenorg.apache.pulsar:pulsar-functions-worker3.1.3GHSA-jg2g-4rjg-cmqh
Mavenorg.apache.pulsar:pulsar-functions-worker3.2.1GHSA-jg2g-4rjg-cmqh

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Pulsar 2.4.0 – before 2.10.62.11.0 – before 2.11.43.0.0 – before 3.0.33.1.0 – before 3.1.33.2.0 – before 3.2.1

Weakness: CWE-22 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:L

References