Vulnerability · Published Feb 28, 2024 · Assigned by apache

CVE-2024-27315Apache Superset: Improper error handling on alerts

Medium 4.3

In plain English

A medium-severity security flaw in Apache Superset from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 62% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)1.0%top 37.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

An authenticated user with privileges to create Alerts on Alerts & Reports has the capability to generate a specially crafted SQL statement that triggers an error on the database. This error is not properly handled by Apache Superset and may inadvertently surface in the error log of the Alert exposing possibly sensitive data. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIapache-superset3.0.4GHSA-h7r6-8qmm-hj5r
PyPIapache-superset3.1.1GHSA-h7r6-8qmm-hj5r
PyPIapache-superset3.0.4, 3.1.1PYSEC-2026-1181

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Superset 0 – before 3.0.43.1.0 – before 3.1.1

Weakness: CWE-209 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

References