Vulnerability · Published Feb 4, 2025 · Assigned by apache
CVE-2024-27137Apache Cassandra: unrestricted deserialization of JMX authentication credentials
Medium 5.3
In plain English
A medium-severity improper authentication in Apache Cassandra from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 21% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
In Apache Cassandra it is possible for a local attacker without access to the Apache Cassandra process or configuration files to manipulate the RMI registry to perform a man-in-the-middle attack and capture user names and passwords used to access the JMX interface. The attacker can then use these credentials to access the JMX interface and perform unauthorized operations. This is same vulnerability that CVE-2020-13946 was issued for, but the Java option was changed in JDK10. This issue affects Apache Cassandra from 4.0.2 through 5.0.2 running Java 11. Operators are recommended to upgrade to a release equal to or later than 4.0.15, 4.1.8, or 5.0.3 which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.apache.cassandra:cassandra-all | 5.0.3 | GHSA-rgfx-7p65-3ff4 |
| Maven | org.apache.cassandra:cassandra-all | 4.1.8 | GHSA-rgfx-7p65-3ff4 |
| Maven | org.apache.cassandra:cassandra-all | 4.0.15 | GHSA-rgfx-7p65-3ff4 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Cassandra | 4.0.2 – before 4.0.154.1.0 – before 4.1.85.0-beta1 – before 5.0.3 |
Weakness: CWE-287 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L