Vulnerability · Published Mar 12, 2024 · Assigned by apache

CVE-2024-27135Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution

High 8.5

In plain English

A high-severity improper input validation in Apache Pulsar from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 6.0% (higher than 93% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.5High
Exploit odds (30 days)6.0%top 6.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper input validation in the Pulsar Function Worker allows a malicious authenticated user to execute arbitrary Java code on the Pulsar Function worker, outside of the sandboxes designated for running user-provided functions. This vulnerability also applies to the Pulsar Broker when it is configured with "functionsWorkerEnabled=true". This issue affects Apache Pulsar versions from 2.4.0 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Pulsar Function Worker users should upgrade to at least 2.10.6. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.4. 3.0 Pulsar Function Worker users should upgrade to at least 3.0.3. 3.1 Pulsar Function Worker users should upgrade to at least 3.1.3. 3.2 Pulsar Function Worker users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.apache.pulsar:pulsar-functions-worker2.10.6GHSA-xp2r-g8qq-44hh
Mavenorg.apache.pulsar:pulsar-functions-worker2.11.4GHSA-xp2r-g8qq-44hh
Mavenorg.apache.pulsar:pulsar-functions-worker3.0.3GHSA-xp2r-g8qq-44hh
Mavenorg.apache.pulsar:pulsar-functions-worker3.1.3GHSA-xp2r-g8qq-44hh
Mavenorg.apache.pulsar:pulsar-functions-worker3.2.1GHSA-xp2r-g8qq-44hh

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Pulsar 2.4.0 – before 2.10.62.11.0 – before 2.11.43.0.0 – before 3.0.33.1.0 – before 3.1.33.2.0 – before 3.2.1

Weakness: CWE-913, CWE-20 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H

References