Vulnerability · Published Mar 27, 2024 · Assigned by GitHub_M

CVE-2024-27091GeoNode stored XSS to full account takeover

Medium 6.1

In plain English

A medium-severity cross-site scripting in geonode from GeoNode. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 32% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)0.4%top 67.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

GeoNode is a geospatial content management system, a platform for the management and publication of geospatial data. An issue exists within GEONODE where the current rich text editor is vulnerable to Stored XSS. The applications cookies are set securely, but it is possible to retrieve a victims CSRF token and issue a request to change another user's email address to perform a full account takeover. Due to the script element not impacting the CORS policy, requests will succeed. This vulnerability is fixed in 4.2.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIgeonode4.2.3GHSA-rwcv-whm8-fmxm
PyPIgeonode4.2.3PYSEC-2024-320

Affected products (as reported)

VendorProductVersions
GeoNode geonode >= 3.2.0, < 4.2.3

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References