Vulnerability · Published Jul 10, 2024 · Assigned by GitHub_M

CVE-2024-27090Decidim vulnerable to data disclosure through the embed feature

Medium 5.3

In plain English

A medium-severity information exposure in decidim from decidim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.5%top 57.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Decidim is a participatory democracy framework, written in Ruby on Rails, originally developed for the Barcelona City government online and offline participation website. If an attacker can infer the slug or URL of an unpublished or private resource, and this resource can be embbeded (such as a Participatory Process, an Assembly, a Proposal, a Result, etc), then some data of this resource could be accessed. This vulnerability is fixed in 0.27.6.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsdecidim0.27.6GHSA-qcj6-vxwx-4rqv

Affected products (as reported)

VendorProductVersions
decidim decidim < 0.27.6

Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

References