Vulnerability · Published Feb 28, 2024 · Assigned by GitHub_M

CVE-2024-26146Possible Denial of Service Vulnerability in Rack Header Parsing

Medium 5.3

In plain English

A medium-severity regular-expression denial of service in rack from rack. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.0% (higher than 81% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)2.0%top 19.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Rack is a modular Ruby web server interface. Carefully crafted headers can cause header parsing in Rack to take longer than expected resulting in a possible denial of service issue. Accept and Forwarded headers are impacted. Ruby 3.2 has mitigations for this problem, so Rack applications using Ruby 3.2 or newer are unaffected. This vulnerability is fixed in 2.0.9.4, 2.1.4.4, 2.2.8.1, and 3.0.9.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8pcs0.10.18-2.el8_10ALSA-2024:2953
AlmaLinux:9pcs0.11.7-2.el9_4ALSA-2024:2113
AlmaLinux:8pcs-snmp0.10.18-2.el8_10ALSA-2024:2953
AlmaLinux:9pcs-snmp0.11.7-2.el9_4ALSA-2024:2113
Debian:12ruby-rack2.2.6.4-1+deb12u1DSA-5698-1
Debian:12ruby-rack2.2.6.4-1+deb12u1DEBIAN-CVE-2024-26146
Debian:13ruby-rack2.2.7-1.1DEBIAN-CVE-2024-26146
Debian:14ruby-rack2.2.7-1.1DEBIAN-CVE-2024-26146
Rocky Linux:8pcs0:0.10.18-2.el8_10RLSA-2024:2953
RubyGemsrack3.0.9.1GHSA-54rr-7fvw-6x8f
RubyGemsrack2.2.8.1GHSA-54rr-7fvw-6x8f
RubyGemsrack2.1.4.4GHSA-54rr-7fvw-6x8f
RubyGemsrack2.0.9.4GHSA-54rr-7fvw-6x8f
Ubuntu:22.04:LTSruby-rack2.1.4-5ubuntu1.1USN-7036-1
Ubuntu:22.04:LTSruby-rack2.1.4-5ubuntu1.1UBUNTU-CVE-2024-26146
Ubuntu:24.04:LTSruby-rack2.2.7-1ubuntu0.1USN-6837-1
Ubuntu:24.04:LTSruby-rack2.2.7-1ubuntu0.1UBUNTU-CVE-2024-26146

Affected products (as reported)

VendorProductVersions
rack rack >= 3.0.0, < 3.0.9.1>= 2.2.0, < 2.2.8.1>= 2.1.0, < 2.1.4.4< 2.0.9.4

Weakness: CWE-1333 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

References