Vulnerability · Published Feb 27, 2024 · Assigned by GitHub_M

CVE-2024-26144Possible Sensitive Session Information Leak in Active Storage

Medium 5.3

In plain English

A medium-severity information exposure in rails from rails. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.2% (higher than 70% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)1.2%top 30.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Rails is a web-application framework. Starting with version 5.2.0, there is a possible sensitive session information leak in Active Storage. By default, Active Storage sends a Set-Cookie header along with the user's session cookie when serving blobs. It also sets Cache-Control to public. Certain proxies may cache the Set-Cookie, leading to an information leak. The vulnerability is fixed in 7.0.8.1 and 6.1.7.7.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rails2:6.1.7.10+dfsg-1~deb12u1DSA-5881-1
Debian:12rails2:6.1.7.10+dfsg-1~deb12u1DEBIAN-CVE-2024-26144
Debian:13rails2:7.2.2.1+dfsg-1DEBIAN-CVE-2024-26144
Debian:14rails2:7.2.2.1+dfsg-1DEBIAN-CVE-2024-26144
RubyGemsactivestorage6.1.7.7GHSA-8h22-8cf7-hq6g
RubyGemsactivestorage7.0.8.1GHSA-8h22-8cf7-hq6g
Ubuntu:24.04:LTSrailsno fix listedUBUNTU-CVE-2024-26144
Ubuntu:25.10railsno fix listedUBUNTU-CVE-2024-26144
Ubuntu:26.04:LTSrailsno fix listedUBUNTU-CVE-2024-26144
Ubuntu:26.10railsno fix listedUBUNTU-CVE-2024-26144

Affected products (as reported)

VendorProductVersions
rails rails >= 5.2.0, < 6.1.7.7>= 7.0.0, < 7.0.8.1

Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

References