Vulnerability · Published Feb 27, 2024 · Assigned by GitHub_M

CVE-2024-26143Rails Possible XSS Vulnerability in Action Controller

Medium 6.1

In plain English

A medium-severity cross-site scripting in rails from rails. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 64% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.1Medium
Exploit odds (30 days)1.0%top 36.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Rails is a web-application framework. There is a possible XSS vulnerability when using the translation helpers in Action Controller. Applications using translation methods like translate, or t on a controller, with a key ending in "_html", a :default key which contains untrusted user input, and the resulting string is used in a view, may be susceptible to an XSS vulnerability. The vulnerability is fixed in 7.1.3.1 and 7.0.8.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
RubyGemsactionpack7.0.8.1GHSA-9822-6m93-xqf4
RubyGemsactionpack7.1.3.1GHSA-9822-6m93-xqf4
RubyGemsrails7.0.8.1GHSA-9822-6m93-xqf4
RubyGemsrails7.1.3.1GHSA-9822-6m93-xqf4
Ubuntu:24.04:LTSrailsno fix listedUBUNTU-CVE-2024-26143
Ubuntu:25.10railsno fix listedUBUNTU-CVE-2024-26143
Ubuntu:26.04:LTSrailsno fix listedUBUNTU-CVE-2024-26143
Ubuntu:26.10railsno fix listedUBUNTU-CVE-2024-26143

Affected products (as reported)

VendorProductVersions
rails rails >= 7.0.0, < 7.0.8.1>= 7.1.0, < 7.1.3.1

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

References