Vulnerability · Published Feb 27, 2024 · Assigned by mitre
CVE-2024-25723
High 8.8
In plain English
A high-severity improper access control in the zenml package (PyPI). Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 70.8% (higher than 99.4% of all known vulnerabilities). Ready-made attack tooling exists: Nuclei, public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | zenml | 0.42.2 | GHSA-vf7j-cmrj-pmmm |
| PyPI | zenml | 0.43.1 | GHSA-vf7j-cmrj-pmmm |
| PyPI | zenml | 0.46.7 | GHSA-vf7j-cmrj-pmmm |
| PyPI | zenml | 0.44.4 | GHSA-vf7j-cmrj-pmmm |
| PyPI | zenml | 0.42.2, 0.43.1, 0.44.4, 0.46.7 | PYSEC-2026-2072 |
Affected products (as reported)
Weakness: CWE-284 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H