Vulnerability · Published Feb 19, 2024 · Assigned by apache
CVE-2024-25710Apache Commons Compress: Denial of service caused by an infinite loop for a corrupted DUMP file
High 8.1
In plain English
A high-severity infinite loop in Apache Commons Compress from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.4%top 61.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in Apache Commons Compress.This issue affects Apache Commons Compress: from 1.3 through 1.25.0. Users are recommended to upgrade to version 1.26.0 which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | libcommons-compress-java | no fix listed | DEBIAN-CVE-2024-25710 |
| Debian:13 | libcommons-compress-java | 1.27.1-1 | DEBIAN-CVE-2024-25710 |
| Debian:14 | libcommons-compress-java | 1.27.1-1 | DEBIAN-CVE-2024-25710 |
| Maven | org.apache.commons:commons-compress | 1.26.0 | GHSA-4g9r-vxhx-9pgx |
| Ubuntu:22.04:LTS | libcommons-compress-java | no fix listed | UBUNTU-CVE-2024-25710 |
| Ubuntu:24.04:LTS | libcommons-compress-java | no fix listed | UBUNTU-CVE-2024-25710 |
| Ubuntu:25.10 | libcommons-compress-java | no fix listed | UBUNTU-CVE-2024-25710 |
| Ubuntu:26.04:LTS | libcommons-compress-java | no fix listed | UBUNTU-CVE-2024-25710 |
| Ubuntu:26.10 | libcommons-compress-java | no fix listed | UBUNTU-CVE-2024-25710 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Commons Compress | 1.3 – through 1.25.0 |
Weakness: CWE-835 · Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H