Vulnerability · Published Nov 6, 2025 · Assigned by GitHub_M

CVE-2024-25621containerd affected by a local privilege escalation via wide permissions on CRI directory

High 7.3

In plain English

A high-severity security flaw in containerd from containerd. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 6% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)0.2%top 93.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

containerd is an open-source container runtime. Versions 0.1.0 through 1.7.28, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4 and 2.2.0-beta.0 through 2.2.0-rc.1 have an overly broad default permission vulnerability. Directory paths `/var/lib/containerd`, `/run/containerd/io.containerd.grpc.v1.cri` and `/run/containerd/io.containerd.sandbox.controller.v1.shim` were all created with incorrect permissions. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. Workarounds include updating system administrator permissions so the host can manually chmod the directories to not have group or world accessible permissions, or to run containerd in rootless mode.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12containerd1.6.20~ds1-1+deb12u2DEBIAN-CVE-2024-25621
Debian:12containerd1.6.20~ds1-1+deb12u2DSA-6067-1
Debian:13containerd1.7.24~ds1-6+deb13u1DEBIAN-CVE-2024-25621
Debian:13containerd1.7.24~ds1-6+deb13u1DSA-6067-1
Debian:14containerd1.7.24~ds1-9DEBIAN-CVE-2024-25621
Gogithub.com/containerd/containerd1.7.29GHSA-pwhc-rpq9-4c8w
Gogithub.com/containerd/containerd1.7.29GO-2025-4100
Gogithub.com/containerd/containerd/v22.0.7, 2.1.5, 2.2.0GO-2025-4100
Gogithub.com/containerd/containerd/v22.2.0GHSA-pwhc-rpq9-4c8w
Gogithub.com/containerd/containerd/v22.1.5GHSA-pwhc-rpq9-4c8w
Gogithub.com/containerd/containerd/v22.0.7GHSA-pwhc-rpq9-4c8w
Ubuntu:22.04:LTScontainerd1.6.12-0ubuntu1~22.04.10UBUNTU-CVE-2024-25621
Ubuntu:25.10containerd1.7.24~ds1-8ubuntu1.1UBUNTU-CVE-2024-25621
Ubuntu:24.04:LTScontainerd-app1.7.28-0ubuntu1~24.04.2UBUNTU-CVE-2024-25621
Ubuntu:25.10containerd-app2.1.3-0ubuntu3.1UBUNTU-CVE-2024-25621

Affected products (as reported)

VendorProductVersions
containerd containerd < 1.7.29>= 2.0.0-beta.0, < 2.0.7>= 2.1.0-beta.0, < 2.1.5>= 2.2.0-beta.0, < 2.2.0

Weakness: CWE-279 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

References