Vulnerability · Published Feb 28, 2024 · Assigned by GitHub_M
CVE-2024-25128Flask-AppBuilder incorrect authentication when using auth type OpenID
Critical 9.1
In plain English
A critical-severity improper authentication in Flask-AppBuilder from dpgaspar. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Flask-AppBuilder is an application development framework, built on top of Flask. When Flask-AppBuilder is set to AUTH_TYPE AUTH_OID, it allows an attacker to forge an HTTP request, that could deceive the backend into using any requested OpenID service. This vulnerability could grant an attacker unauthorised privilege access if a custom OpenID service is deployed by the attacker and accessible by the backend. This vulnerability is only exploitable when the application is using the OpenID 2.0 authorization protocol. Upgrade to Flask-AppBuilder 4.3.11 to fix the vulnerability.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | flask-appbuilder | 4.3.11 | GHSA-j2pw-vp55-fqqj |
| PyPI | flask-appbuilder | 4.3.11 | PYSEC-2026-340 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| dpgaspar | Flask-AppBuilder | < 4.3.11 |
Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N