Vulnerability · Published Feb 28, 2024 · Assigned by apache
CVE-2024-24772Apache Superset: Improper Neutralisation of custom SQL on embedded context
Medium 4.3
In plain English
A medium-severity SQL injection in Apache Superset from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.0% (higher than 61% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | apache-superset | 3.0.4 | GHSA-m6jm-3v38-76j4 |
| PyPI | apache-superset | 3.1.1 | GHSA-m6jm-3v38-76j4 |
| PyPI | apache-superset | 3.0.4, 3.1.1 | PYSEC-2026-1185 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Superset | 0 – before 3.0.43.1.0 – before 3.1.1 |
Weakness: CWE-89 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
References
- https://lists.apache.org/thread/gfl3ckwy6y9tpz9jmpv62orh2q346sn5 vendor-advisory
- http://www.openwall.com/lists/oss-security/2024/02/28/5 x_transferred