Vulnerability · Published Feb 16, 2024 · Assigned by GitHub_M

CVE-2024-24758Proxy-Authorization header not cleared on cross-origin redirect in fetch in Undici

Low 3.9

In plain English

A low-severity information exposure in undici from nodejs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.9Low
Exploit odds (30 days)0.8%top 44.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Undici is an HTTP/1.1 client, written from scratch for Node.js. Undici already cleared Authorization headers on cross-origin redirects, but did not clear `Proxy-Authentication` headers. This issue has been patched in versions 5.28.3 and 6.6.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-undicino fix listedDEBIAN-CVE-2024-24758
Debian:13node-undici5.28.4+dfsg1+~cs23.12.11-1DEBIAN-CVE-2024-24758
Debian:14node-undici5.28.4+dfsg1+~cs23.12.11-1DEBIAN-CVE-2024-24758
Ubuntu:24.04:LTSnode-undicino fix listedUBUNTU-CVE-2024-24758
Ubuntu:25.10node-undicino fix listedUBUNTU-CVE-2024-24758
Ubuntu:26.04:LTSnode-undicino fix listedUBUNTU-CVE-2024-24758
Ubuntu:26.10node-undicino fix listedUBUNTU-CVE-2024-24758
npmundici6.6.1GHSA-3787-6prv-h9w3
npmundici5.28.3GHSA-3787-6prv-h9w3

Affected products (as reported)

VendorProductVersions
nodejs undici < 5.28.3>= 6.0.0, < 6.6.1

Weakness: CWE-200 · Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:L

References