Vulnerability · Published Feb 1, 2024 · Assigned by GitHub_M

CVE-2024-24753Bref Multiple Value Headers Not Supported in ApiGatewayFormatV2

Medium 4.8

In plain English

A medium-severity security flaw in bref from brefphp. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.8Medium
Exploit odds (30 days)0.4%top 63.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Bref enable serverless PHP on AWS Lambda. When Bref is used in combination with an API Gateway with the v2 format, it does not handle multiple values headers. If PHP generates a response with two headers having the same key but different values only the latest one is kept. If an application relies on multiple headers with the same key being set for security reasons, then Bref would lower the application security. For example, if an application sets multiple `Content-Security-Policy` headers, then Bref would just reflect the latest one. This vulnerability is patched in 2.1.13.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistbref/bref2.1.13GHSA-99f9-gv72-fw9r

Affected products (as reported)

VendorProductVersions
brefphp bref < 2.1.13

Weakness: CWE-436 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

References