Vulnerability · Published Feb 5, 2024 · Assigned by GitHub_M

CVE-2024-24574phpMyFAQ vulnerable to stored XSS on attachments filename

Medium 6.5

In plain English

A medium-severity cross-site scripting in phpMyFAQ from thorsten. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.9% (higher than 59% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.9%top 40.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. Unsafe echo of filename in phpMyFAQ\phpmyfaq\admin\attachments.php leads to allowed execution of JavaScript code in client side (XSS). This vulnerability has been patched in version 3.2.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Packagistphpmyfaq/phpmyfaq3.2.5GHSA-7m8g-fprr-47fx

Affected products (as reported)

VendorProductVersions
thorsten phpMyFAQ < 3.2.5

Weakness: CWE-79, CWE-80 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L

References