Vulnerability · Published Jan 31, 2024 · Assigned by GitHub_M

CVE-2024-24566Lobe Chat unauthorized access to plugins

Medium 5.3

In plain English

A medium-severity improper access control in lobe-chat from lobehub. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.3Medium
Exploit odds (30 days)0.5%top 58.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Lobe Chat is a chatbot framework that supports speech synthesis, multimodal, and extensible Function Call plugin system. When the application is password-protected (deployed with the `ACCESS_CODE` option), it is possible to access plugins without proper authorization (without password). This vulnerability is patched in 0.122.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@lobehub/chat0.122.4GHSA-pf55-fj96-xf37

Affected products (as reported)

VendorProductVersions
lobehub lobe-chat < 0.122.4

Weakness: CWE-284 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

References