Vulnerability · Published Jan 30, 2024 · Assigned by GitHub_M
CVE-2024-24556XSS in @urql/next
High 7.2
In plain English
A high-severity cross-site scripting in urql from urql-graphql. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
urql is a GraphQL client that exposes a set of helpers for several frameworks. The `@urql/next` package is vulnerable to XSS. To exploit this an attacker would need to ensure that the response returns `html` tags and that the web-application is using streamed responses (non-RSC). This vulnerability is due to improper escaping of html-like characters in the response-stream. To fix this vulnerability upgrade to version 1.1.1
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @urql/next | 1.1.1 | GHSA-qhjf-hm5j-335w |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| urql-graphql | urql | < 1.1.1 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N